1401 Technoligy Drive - Phone Service Outage
Incident Report for James Madison University
Resolved
At this time, all services have been restored for 1401 Technology drive. If you are still experiencing issue, please contact the IT Help Desk at 540-568-3555.
Posted Sep 18, 2024 - 12:57 EDT
Investigating
JMU IT Telecom is currently investigating an issue at 1401 Technology Drive. Presently, Phone service is down and not allowing incoming or outgoing calls. The 911 services is still available. Once additional information is available, an update will be posted.

If you have any question, please contact the JMU IT Help Desk at 540-568-3555.
Posted Sep 18, 2024 - 08:53 EDT