Callling Issues to Verizon Customer

Incident Report for James Madison University

Update

The issue has been resolved and service has been retored.
Posted Sep 09, 2026 - 16:45 EDT

Update

We are continuing to investigate this issue.
Posted Sep 09, 2026 - 08:31 EDT

Investigating

JMU is currently experiencing issues with outbound calls to Verizon Wireless and Verizon landline customers. Some calls may fail to connect. Telecom is currently investigating and has submitted a ticket to Verizon. Updates to continue as they become available.
Posted Sep 08, 2026 - 16:29 EDT
This incident affects: JMU Telecom (Verizon).