Outage: Users may not be able to download Microsoft 365 desktop apps

Incident Report for James Madison University

Resolved

At this time, Microsoft has reported that they have confirmed download functionality for Microsoft 365 desktop apps has been restored and the issue is fully remediated.

If you have questions or are still experiencing issues, please reach out to the IT Help Desk at 540-568-3555 or submit a request through the IT Service Portal.
Posted Dec 04, 2025 - 12:31 EST

Investigating

JMU IT Has been made aware that users may not be able to download Microsoft 365 desktop apps from the Microsoft 365 homepage. Microsoft is currently working to resolve the issue and implement a fix.

For any questions, please reach out to the JMU IT Help Desk at 540-568-3555 or submit a request through the IT Service Portal at its.jmu.edu.
Posted Dec 04, 2025 - 08:15 EST
This incident affected: Microsoft 365 (Microsoft 365).