Comcast Service Disruption

Incident Report for James Madison University

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 11:39 EST

Identified

Comcast will be performing network upgrades in the Harrisonburg area on December 11, 2025, starting at 5:00 AM. Service may be intermittently unavailable throughout the day. Updates will be posted as they become available.
Posted Dec 05, 2025 - 13:36 EST
This incident affected: Telecom (Comcast).