Telecom Sevice Disruption - 1598 S. Main Street

Incident Report for James Madison University

Update

We are continuing to investigate this issue.
Posted Sep 05, 2026 - 22:15 EDT

Investigating

Telecom services are experiencing intermittent connectivity issues. Verizon has been notified. Telecom will continue to monitor the connection and provide updates as additional information becomes available.
Posted Sep 05, 2026 - 21:31 EDT
This incident affects: JMU Telecom (Verizon).