1070 VA. Ave. - Verizon CCIS is down

Incident Report for James Madison University

Update

CCIS LINK VERIZON CARRIER ISSUE RESOLVED.
Posted Mar 05, 2026 - 16:53 EST

Investigating

Telecom is aware of the CCIS link outage at 1070 VA Avenue and is actively investigating. Occupants are currently unable to make or receive calls, but can call 911.
Posted Mar 05, 2026 - 13:33 EST
This incident affects: Telecom (Verizon).