Outage: Duo

Incident Report for James Madison University

Resolved

Resolved - We can now confirm that all services have been completely restored. A full RCA will be provided as soon as possible. Thank you for your patience, while we worked to resolve the issues.
Feb 13, 20:43 EST
Posted Feb 14, 2025 - 07:23 EST

Identified

Identified - We have identified the issue causing Admin Panel login, Device Management Portal, Risk-based Authentication, and SMS/Phone Call delivery failures across all deployments and are working to deploy a fix.

If you have your Admin Panel URL saved, you can navigate to the URL (ex. admin-xxxxxxxx.duosecurity.com/) to get direct access.

When accessing the Admin Panel, please utilize non-telephony-based MFA methods to ensure proper access. Admin's currently logged in can activate Duo Push for other admins following this documentation: https://duo.com/docs/administration-admins#updating-an-administrator's-secondary-authentication-methods
Feb 13, 2025 - 14:01 EST
Posted Feb 13, 2025 - 14:49 EST

Update

We are continuing to investigate this issue.
Posted Feb 13, 2025 - 13:51 EST

Investigating

Investigating - We are currently investigating an issue causing Admin Panel login and SMS/Phone Call delivery failures across all deployments.

If you can access your Admin Panel, please utilize our other MFA methods such as Push, Passcodes, Hardware Tokens, and Security Keys in the meantime. https://duo.com/docs/policy#authentication-methods

Please check back here or subscribe to updates for any changes.
Posted Feb 13, 2025 - 13:28 EST